依星源码资源网,依星资源网

 找回密码
 立即注册

QQ登录

只需一步,快速开始

福运盘济宁依星网络八字排盘系统
查看: 4|回复: 0

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境

[复制链接] 主动推送

3万

主题

3万

帖子

3万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
34735
发表于 1 小时前 | 显示全部楼层 |阅读模式
java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境
安卓App已适配GB28181, 可以集成国标监控平台; 集成公网对讲、28181的IPC、执Fa记录仪、IP/PBX及SIP电话、提供WebRTC音视频通话、基于WebRTC SFU架构实现音视频会议 (提供端到端安全的百人会议解决方案),支持全内网、私有化部署,支持信创,在大型央国企有重要应用。
平台是典型云服务器+微服务+C/S+B/S的架构,平台采用多租户模型,可以布署于公网,也可以灵活布署于局域网运行。
1.1 对讲平台(自主的对讲云服务,非Sip协议对讲)
包含语音对讲、定位轨迹、电子围栏及音视频调度,基于自主的对讲云服务
1.2 SIP国标对讲平台(Sip协议对讲)
SIP国标对讲,采用RFC 3261国际标准,以及国内标准系列,如公安部发布的ePDT融合协议(pSIP)等,应广大企业和开发者的强烈需求,该平台即将发布
1.2.1 SIP 协议介绍
全称: Session Initiation Protocol,它是当前全球互联网和通信行业中的核心规范,由互联网工程任务组(IETF)在 2002 年 6 月发布 RFC 3261技术规范,与RFC 3261相关补允标准有(仅列举常用的)
  • RFC 3265:SIP Specific Event Notification(定义了SUBSCRIBE/NOTIFY)
  • RFC 3856:Presence事件包(定义了presence事件)
  • RFC 3903:PUBLISH方法(发布事件状态)
  • RFC 3428: 定义了 MESSAGE 方法,用于在 SIP 会话外直接发送类似 SMS 的即时消息
  • RFC 4566: 定义了SDP协议,用于音视频沟通
  • RFC 7118: 定义了如何将 SIP 协议封装在 WebSocket 协议中进行传输。主要解决了在 Web 浏览器环境中实现 SIP 通信的问题,使得 Web 应用可以通过 JavaScript 使用 SIP 进行音视频通话和即时消息

sip协议是一种类似于http协议的对等协议(peer-to-peer)即作为请求又含响应,且是一种异步协议(靠内部事务中各种定时器,如Timer A,B,D,M,G,H,I,L等等处理超时和回调), 由于sip开发心智负担大,目前基于sip的开发栈有:
  • c/c++栈:PJSIP (大厂都在用,如华为、中兴、海能达等一线大厂)
  • java栈:jain-sip-ri.1.3.0-x.jar (Wvp-GB28181-pro作者用了此依赖),高级框架:JSR 289: Sip Servlet 1.1(这个开发起来比较愉快!)
  • web栈: sip.js
  • sip应用服务器:Asterisk,FreeSwitch等
1.3 音视频通话平台
支持内网(基站)部署方案:
  • 内网采用WebRTC方案, 集成说明,里面有详细源代码公开, 桌面应用与移动应用内网webrtc通话流程

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...
1.4 集成WebRTC SFU架构的音视频会议
提供端到端加密(e2ee)实现音视频传输
提供企业内部代替“腾讯会议”的方案
支持会议中调度台分享、APP分享桌面
支持会议录制,录制加水印
支持会议中途邀请
支持调度台之间级联会议
支持会议中回音消除、适配弱网流畅优先
支持全内网部署,内网千兆带宽下支持近百人开语音或视频会议

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...
1.5 集成到GB28181平台
集成了强大的开源流媒体服务ZLMediaKit和 SIP服务 Wvp-GB28181-pro框架,并在此基础上扩展了公网对讲终端的GB28181协议接入,实现注册、注销、终端音视频实时点播、录像、下载等功能。
  • 目前支持android或单兵终端的H264编码,打包成 PS流上传到GB28181平台;
  • 自动判断硬件是否支持 H265硬编码,如果支持自动H265硬编码并打包成PS流上传到GB28181平台;
  • 支持终端前摄、后摄、USB(OTG)摄像头的全部 H264或 H265上传PS流;
  • 打包的PS流与海康、大华、宇视等厂家兼容,自动对VPS、PPS、SPS及 I、P、B等帧的封包处理。
  • 支持AAC音频采集打包成 PS流上传到GB28181平台;
2、二次开发与代码集成
本平台提供了API与协议对接,同时提供绝大多数客户端源代码开放,所有的第三方开发者或企业可以在此基础上定制和二次开发
[td]
客户端源代码适配硬件终端源代码相对位置目录集成和源代码说明
Android app兼容安卓手机、国内绝大多数厂商安卓公网对讲机或平板终端、单兵终端等demo\android_app集成说明
iot嵌入式app兼容移远模组EC600x/EC800x系列开发板demo\iot_app集成说明
PC桌面端应用Windows10及11pc_app待补充...
Web平台应用为Edge、Chrome浏览器提供插件方案,可以将对讲快速集成到web应用webplugin\chrome集成说明
Electron应用提供eclectron对讲插件,快速集成webplugin\electron集成说明
3、本平台提供的对讲方案[td]
公网集群对讲
开发说明本平台支持语音编解码有AMR-NB、PCMA、PCMU、Opus等
组呼支持固定组呼
支持地图框选组呼
临时组呼支持动态创建组呼,退出释放
组呼监听支持调度台监听任意多个组讲话或取消监听
APP端监听暂不支持
单呼支持一对一对讲单呼
请求与应答模式
广播呼叫支持调度台语音广播
支持调度台录音文件广播
应急广播后,组员自动返回到上一个组
强踢/插支持调度台端对临时组强踢与强插成员
遥晕/毙支持按帐号遥晕
支持遥毙
麦权等级支持三个麦权等级,更多等级需要定制
对讲插话支持同组内高麦权等级实时打断低麦权等级讲话
对讲录音支持实时录音,存于服务器
支持在线查询、播放和下载
对讲组织层次支持对讲组织按类似于行政区划组织成树状(不限层级数量)
对讲组织节点显示在线数/总人数,且按递归统计
SOS呼叫支持终端一键呼叫调度台,无需麦权
支持同时上报定位和视频推流
4、本平台提供的音视频方案[td]
公网/内网统一部署
方案说明1.适用于内网部署
2.集成ZLM与WebRTC,无额外费用
3.架构原理
1对1音视频通话 支持1对1音频频通话
视频码率动态适配,信号弱时流畅优先
视频监控支持不同分辨率调取监控,终端无感知
码率动态适配,信号弱时流畅优先
视频支持H264/H265编码,音频支持PCMA/U,AAC等编码
支持推流和拉流鉴权
视频直播支持不同分辨率直播
码率动态适配,信号弱时流畅优先
视频分享转发支持转发流
终端拉流播放
视频录像服务端同步录像
录像支持时间切片
支持在线点播和下载
一键SOS视频呼叫支持SOS一键定位、语音、视频三位一体同步呼叫和通知调度台
视频会议支持100路以上视频会商

  • 视频监控/直播简单应用图例

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

视频监控(停车场复杂应用,扩展到64路道闸相机)

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...


二、信创产业适配
  • 服务端操作系统支持统信,中标麒麟,银河麒麟,欧拉
  • 数据库支持人大金仓
  • Web版调度台
  • 浏览器支持:360安全浏览器、微软Edge、Google Chrome浏览器,全部原生支持无需插件安装
  • web版主要模块有:首页大屏、群组对讲、IPC摄像头(海康、大华、宇视、天地伟业、华为等)接入、执.fa记录仪接入、定位轨迹、电子围栏、离线地图、视频/语音通话、视频图传与分享、视频会议及录音录像等等

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...

java一款重量级的对讲与视频监控、音视频融合通讯综合平台,可用于公网、企业局域网和基站及政企环境 ...



链接: https://pan.baidu.com/s/1Imvw5_zoVYGfpxMKAjNJcg
提取码下载:
文件名称:提取码下载.txt 
下载次数:0  文件大小:16 Bytes  售价:199金钱 [记录]
下载权限: 不限 [购买VIP]   [充值]   [在线充值]   【VIP会员6折;永久VIP4折】
安全检测,请放心下载




相关帖子

扫码关注微信公众号,及时获取最新资源信息!【下载附件优惠:VIP会员6折;永久VIP4折】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

免责声明:
1、本站提供的所有资源仅供参考学习使用,版权归原著所有,禁止下载本站资源参与商业和非法行为,请在24小时之内自行删除!
2、本站所有内容均由互联网收集整理、网友上传,并且以计算机技术研究交流为目的,仅供大家参考、学习,请勿任何商业目的与商业用途。
3、若您需要商业运营或用于其他商业活动,请您购买正版授权并合法使用。
4、论坛的所有内容都不保证其准确性,完整性,有效性,由于源码具有复制性,一经售出,概不退换。阅读本站内容因误导等因素而造成的损失本站不承担连带责任。
5、用户使用本网站必须遵守适用的法律法规,对于用户违法使用本站非法运营而引起的一切责任,由用户自行承担
6、本站所有资源来自互联网转载,版权归原著所有,用户访问和使用本站的条件是必须接受本站“免责声明”,如果不遵守,请勿访问或使用本网站
7、本站使用者因为违反本声明的规定而触犯中华人民共和国法律的,一切后果自己负责,本站不承担任何责任。
8、凡以任何方式登陆本网站或直接、间接使用本网站资料者,视为自愿接受本网站声明的约束。
9、本站以《2013 中华人民共和国计算机软件保护条例》第二章 “软件著作权” 第十七条为原则:为了学习和研究软件内含的设计思想和原理,通过安装、显示、传输或者存储软件等方式使用软件的,可以不经软件著作权人许可,不向其支付报酬。若有学员需要商用本站资源,请务必联系版权方购买正版授权!
10、本网站如无意中侵犯了某个企业或个人的知识产权,请来信【站长信箱312337667@qq.com】告之,本站将立即删除。
郑重声明:
本站所有资源仅供用户本地电脑学习源代码的内含设计思想和原理,禁止任何其他用途!
本站所有资源、教程来自互联网转载,仅供学习交流,不得商业运营资源,不确保资源完整性,图片和资源仅供参考,不提供任何技术服务。
本站资源仅供本地编辑研究学习参考,禁止未经资源商正版授权参与任何商业行为,违法行为!如需商业请购买各资源商正版授权
本站仅收集资源,提供用户自学研究使用,本站不存在私自接受协助用户架设游戏或资源,非法运营资源行为。
 
在线客服
点击这里给我发消息 点击这里给我发消息 点击这里给我发消息
售前咨询热线
312337667

微信扫一扫,私享最新原创实用干货

QQ|免责声明|小黑屋|依星资源网 ( 鲁ICP备2021043233号-3 )|网站地图

GMT+8, 2026-10-7 21:49

Powered by Net188.com X3.4

邮箱:312337667@qq.com 客服QQ:312337667(工作时间:9:00~21:00)

快速回复 返回顶部 返回列表