查看: 36|回复: 0

    Cannot change version of project facet Dynamic Web Module to 3.0 问题错误

    [复制链接]

    242

    主题

    242

    帖子

    577

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    577
    发表于 2022-4-24 09:41:15 | 显示全部楼层 |阅读模式
    【eclipse】Cannot change version of project facet Dynamic Web Module to 3.0 问题错误
    eclipse错误内容:Description Resource Path Location Type:Cannot change version of project facet Dynamic Web Module to 3.0.
    1.png
    这个问题会导致项目代码不出现任何问题的情况下,项目报错但是依然可以运行。
    2.png
    问题原因:项目Web版本配置不匹配,如果报错问题是Tomcat的话,同样是Tomcat版本配置不匹配的问题。

    解决方法:

    1、在计算机中找到自己的Eclipse的工作空间,找到自己报错的项目,双击打开,如下图所示。

    3.png

    2、双击.settings文件夹,找到org.eclipse.wst.common.project.facet.core.xml,用编辑器或者记事本打开,如下图所示。
    4.png
    5.png
    4、此时我们发现配置文件里的jst.web version = 3.1 而我的项目里web.xml的配置版本为3.0,因此出现冲突,将两者改为相同的版本即可。如果是Tomcat的报错,便在此记事本中将Apache Tomcat v8.5进行修改成一样的版本即可。

    5、打开Eclipse,找到报错的项目右键,选择maven,然后选择update project,将force update勾选上,点击OK,项目不再报错。


    6.png
    错误分析:由于代码配置和eclipse中的配置文件版本不匹配所导致的问题。


    文章转载出处:https://blog.csdn.net/qq_49306973/article/details/120127957




    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    免责声明:
    1、转载或引用本网站内容须注明原网址,并标明本网站网址“源码资源网”
    2、转载或引用本网站中的署名文章,请按规定向原作者支付稿酬
    3、对于不当转载或引用本网站内容而引起的民事纷争、行政处理或其他损失,本网站不承担责任
    4、对不遵守本声明或其他违法、恶意使用本网站内容者,本网站保留追究其法律责任的权利
    5、资源部分来自网络,不保证资源的完整性,仅供学习研究,如需运营请购买正版,如有侵权请联系客服删除
    6、本站所有资源不带技术支持,下载资源请24小时内删除,如用于违法用途,或者商业用途,一律用于者承担

    QQ|手机版|小黑屋|源码资源网 ( 鲁ICP备2021043233号-3 )

    GMT+8, 2022-5-22 02:53

    邮箱:312337667@qq.com 客服QQ:312337667(工作时间:7:00~23:00)

    © Powered by Net188.com X3.4

    快速回复 返回顶部 返回列表